Multicast over GRE between Linux server and Cisco Router

Tom Ammon thomasammon at gmail.com
Sat Jan 19 03:07:46 UTC 2013


IGMP packets are sent with TTL=1. Is the tunnel interface on the router
enabled for PIM?

Tom


On Fri, Jan 11, 2013 at 5:11 AM, Brian Christopher Raaen <
mailing-lists at brianraaen.com> wrote:

> Just a quick note. I do have multicast enabled on the server gre1
> interface.  A tshark capture shows the igmp group queries from the router
> and the igmp join reply from the server.
>
>
> On Wed, Jan 9, 2013 at 10:51 AM, Brian Christopher Raaen <
> mailing-lists at brianraaen.com> wrote:
>
> > I am trying to set up multicast between a Linux server and Router using
> > GRE.  The GRE tunnel is up fine and I can see traffic go across it, but
> the
> > router is not indicating it is receiving the IGMP joins that the server
> is
> > sending.  I have identical setting with another server attached to
> > fastethernet0/1 and it is joined to the group fine, but I am not able to
> > get the server to link to the router via GRE interface.  Note that I have
> > another server behind another router where the two routers do GRE and PIM
> > and that on is working fine.  Is there some reason that IGMP joins would
> > not work across the GRE link, but another router using PIM would?
> >
> > --
> > Brian Christopher Raaen
> > Network Architect
> > Zcorum
> >
>
>
>
> --
> Brian Christopher Raaen
> Network Architect
> Zcorum
>



-- 
-----------------------------------------------------------------------------
Tom Ammon
Network Engineer
M: (801) 674-9273
tom at tomsbox.net
-----------------------------------------------------------------------------


More information about the NANOG mailing list