Proving Gig Speed

Carlos Alcantar carlos at race.com
Mon Jul 16 20:31:13 UTC 2018


It's a complete rabbit hole different hardware with different browsers give different readings, even not having your laptop plugged into power can cause a change in results due to dropping cpu to power save.  The only reliable solution we found for field techs was the exfo ex1.    Still talks to the ookla speedtest server etc.  Obvious this is a well known issue and exfo has a solution.



https://www.exfo.com/en/products/field-network-testing/network-protocol-testing/ethernet-testing/ex1/





Carlos Alcantar

Race Communications / Race Team Member

Phone: +1 415 376 3314 / carlos at race.com<mailto:carlos at race.com> / http://www.race.com<http://www.race.com/>



________________________________
From: NANOG <nanog-bounces at nanog.org> on behalf of Chris Gross <CGross at ninestarconnect.com>
Sent: Monday, July 16, 2018 12:39 PM
To: Matt Erculiani
Cc: North American Network Operators' Group
Subject: RE: Proving Gig Speed

Winner winner chicken dinner. I forgot to pull "Antivirus is at fault" card from my deck. 250/675 with it installed, 920/920 when removed so now I get to pass the the issue onwards.

Thanks everyone for your replies and the responses for the adolfintel/speedtest github, I'll definitely look at it as a replacement for later.

-----Original Message-----
From: Matt Erculiani <merculiani at gmail.com>
Sent: Monday, July 16, 2018 2:17 PM
To: Chris Gross <CGross at ninestarconnect.com>
Cc: North American Network Operators' Group <nanog at nanog.org>
Subject: Re: Proving Gig Speed

We use Iperf3 for customers that complain about throughput, it's relatively low overhead compared to the Ookla HTML5 client. Same scenario as you, we have the tech hook up their laptop to the customer's drop and perform testing. I suspect your antivirus may be attempting to perform real-time inspection on the http(s) traffic, which would crush the little laptop CPU for sure.

Message me off-list and I'll send you a private Iperf3 server IP to test with.

-Matt

On Mon, Jul 16, 2018 at 12:58 PM, Chris Gross <CGross at ninestarconnect.com> wrote:
> I'm curious what people here have found as a good standard for providing solid speedtest results to customers. All our techs have Dell laptops of various models, but we always hit 100% CPU when doing a Ookla speedtest for a server we have on site. So then if you have a customer paying for 600M or 1000M symmetric, they get mad and demand you prove it's full speed. At that point we have to roll out different people with JDSU's to test and prove it's functional where a Ookla result would substitute fine if we didn't have crummy laptops possibly. Even though from what I can see on some google results, we exceed the standards several providers call for.
>
> Most of these complaints come from the typical "power" internet user of course that never actually uses more than 50M sustained paying for a residential connection, so running a circuit test on each turn up is uncalled for.
>
> Anyone have any suggestions of the requirements (CPU/RAM/etc) for a laptop that can actually do symmetric gig, a rugged small inexpensive device we can roll with instead to prove, or any other weird solution involving ritual sacrifice that isn't too offensive to the eyes?


More information about the NANOG mailing list