10G switch drops traffic for a split second

TJ Trout tj at pcguys.us
Tue Nov 29 21:28:22 UTC 2016


All l2, no l3. only 4 vlans. 2 peers trunked to a router which trunks back
to 2 devices (microwave backhauls).


All ports are 10g except the 2 peers are 1g and trunk back to a 10g port
for the router wan

No TCN's


I have tried a IBM G8124 and a Ubiquiti ES-16-XG both show same exact drops
across all ports, makes me think it's a config issue. MTU, FC, something.


I have tried with FC disabled, but I will try that one more time.


Is it possible to over run the buffers of a 320gbps backplane switch with
only 1.5gbps traffic? I think the switch is rated for 140m PPS and I'm only
pushing 100k PPS

On Tue, Nov 29, 2016 at 9:47 AM, Mikael Abrahamsson <swmike at swm.pp.se>

> On Tue, 29 Nov 2016, TJ Trout wrote:
> Could this be MTU? I've tried flow control, hard code duplex, stp on/off
>> etc
> As others have pointed out, you probably have a switch with small buffers.
> If you also have flow control and you have something that triggers flow
> control to turn off packet forwarding, your small-buffer-switch might fill
> up all (shared) buffers on that port and now you're dropping traffic to all
> ports.
> So trying to find if you have something where flow control is enabled and
> is being triggered might be something worthwhile to do, and also perhaps
> just turn off flow control on all ports to make sure.
> --
> Mikael Abrahamsson    email: swmike at swm.pp.se

More information about the NANOG mailing list