Applications that break when not using /64

Jeroen Massar jeroen at
Wed Jun 18 10:39:21 UTC 2014

On 2014-06-18 12:31, Grzegorz Janoszka wrote:
> On 17/06/14 23:13 , Jeroen Massar wrote:
>> Thus, can you please identify these applications so that we can hammer
>> on the developers of those applications and fix that problem?
> I haven't done extensive testing. I have just tried to divide a /64 into
> smaller subnets and to run Debian and Windows on it (as Matthew Petach
> did with his FreeBSD). I think I have tried /112 or /120. Debian was
> mostly fine, just one torrent or newsgroups client couldn't do v6 (can't
> recall which one), with Windows it was a different story and basically
> nothing really worked.

Why would a torrent client care about the prefix length?

But anyway, you had some random application that nobody uses that was
broken, seems to be a problem with that specific application, not
anything else.

> It was some time ago and I haven't tried Windows 7 SP1, maybe it has
> been fixed till now. Does anyone have Windows with IPv6 and netmask > /64?

I've only played with the NT4, Win2k, XP, and Vista stacks, and these
work fine in every scenario (/64 SLAAC, or /128 static config).

Hence you'll need to provide a lot more details than "it didn't work"...


More information about the NANOG mailing list