Managing IOS Configuration Snippets

Ryan Shea ryanshea at google.com
Fri Feb 28 15:51:53 UTC 2014


Isn't that framework called Juniper Op scripts? Run command which takes xml
output of config (or other RPC) applies xslt, produces the output you
describe.


On Fri, Feb 28, 2014 at 10:24 AM, Leo Bicknell <bicknell at ufp.org> wrote:

>
> On Feb 27, 2014, at 7:38 PM, Keegan Holley <no.spam at comcast.net> wrote:
>
> > Putting aside the fact that snippets aren’t a good way to conceptualize
> deployed router code, my gut still tells me to question the question here.
>
> What I have always wanted is a way to group configuration, in particular
> by customer.  Ideally with the ability to see it both as a unified view,
> and also as a per-customer view.
>
> For instance:
>
> customer AAAAA
>   interface GigabitEthernet1/2/3.10
>     description AAAAA
>     ip address 10.0.1.1 255.255.255.0
>   router bgp 1
>     neighbor 10.0.1.2 prefix-list AAAAA-in in
>   ip prefix-list AAAAA-in 10.1.0.0/24
> end
>
> customer BBBBB
>   interface GigabitEthernet1/2/3.11
>     description BBBBB
>     ip address 10.0.2.1 255.255.255.0
>   router bgp 1
>     neighbor 10.0.2.2 prefix-list BBBBB-in in
>   ip prefix-list BBBBB-in 10.2.0.0/24
> end
>
> Then I should be able to do:
>
> show run - Normal output like we see today, the "device" view.
> customer AAAAA show run - Same format as I have above, just config
> relevant to customer AAAAA.
>
> I can even see extending the tag to work with some other commands:
>
> customer AAAAA show int
> customer AAAAA show bgp ipv4 uni sum
> customer AAAAA show ip prefix-list
>
> The same functionality would work for snippets:
>
> customer ntp-servers-v1.0
>  ntp server 1.2.3.4
>  ntp server 1.2.3.5
>  ntp server 1.2.3.6
> end
>
> Basically this follows the two modes in which engineers look at a device.
>  Most of the time is configuring a specific customer, and wanting to be
> sure they are configured right; including the hard case of "no customer
> AAAAA", that is making sure all configuration for a specific customer is
> removed.  The rest of the time is typically troubleshooting a network level
> problem where you want the device view we have today, I see interface
> Gig1/2/3 is dropping packets, "show run" to see who's configure on it sort
> of operations.
>
> I don't know of any platform that has implemented this sort of config
> framework though.
>
> --
>        Leo Bicknell - bicknell at ufp.org - CCIE 3440
>         PGP keys at http://www.ufp.org/~bicknell/
>
>
>
>
>
>


More information about the NANOG mailing list