Google public DNS - getting SERVFAIL for any domains delegated to GoDaddy NSs

Erik Levinson erik.levinson at
Sun Dec 7 17:44:36 UTC 2014

On 07/12/14 12:19 PM, Stephane Bortzmeyer wrote:
> Since Google Public DNS validates, and Go Daddy supports DNSSEC, it
> would be useful to test with dig +cd (Checking Disabled) to determine
> if it is a DNSSEC problem or not.
Tried, still SERVFAIL. I succeeds with +trace though...

>> You can look at as one example (should be just an A
>> record to but getting SERVFAIL when querying
> Works for me
Maybe a geo-specific issue then, which is even more weird, because it's 
still not working for me from two different ASs, though both in Toronto, 
and a traceroute makes it appear like they're not hitting the same nodes 
(but maybe they are).

What's even more weird is I can actually resolve one domain,, but still not and others.

Erik Levinson
CTO, Uberflip
1183 King Street West, Suite 100
Toronto ON  M6K 3C5

More information about the NANOG mailing list