AT&T UVERSE Native IPv6, a HOWTO

Andrew D Kirch trelane at trelane.net
Sat Nov 23 06:22:02 UTC 2013


Special thanks to Alexander from AT&T's "Tier-2" dept, though my 
suspicion is that that is not where he works, as he seems exceptionally 
clueful.
Additional thanks to Owen DeLong who finally got me off my ass to 
actually do this, I'll see you in the sky!

Ok, is this core routing? not really, but it's nice to see a major clue 
injection over at AT&T Uverse.  I'm using this to document the MASSIVE 
bureaucratic PITA which is getting native IPv6 on uverse.  You'll start 
from the default service on a 2wire "modem" (for values of modem that 
equate to profanity).  If you have the Motorola NVG589, count yourself 
lucky and skip most of these steps.

  Abandon all hope ye who enter here....

Step 1: contact AT&T Uverse support and complain that you need IPv6 
(because we all need it, I in fact do for work).
Step 2: general confusion as the level 1 droid doesn't know what IPv6 
is, politely request to be transferred to tier 2
step 3: you will be told that tier 2 is a paid service, invoke the 
almighty FCC and ask to speak with a supervisor, expect a long hold here.
step 4: you arrive at tier 2, mention that IPv6 won't work on your 2wire 
and that AT&T has broken your protocol 41 tunnel with <insert tunnel 
broker here, usually HE>
step 5: you'll need to get your 2wire replaced with a Motorola NVG589.  
Again you will be threatened with a cost to upgrade, mine was waived due 
to the work requirement.  I'd guess some additional complaining and 
escalation will get this fee waived.  My recollection was it was $100.  
The new modem is good news for quite a few reasons, the 2wire sucks, the 
Motorola sucks significantly less, and has a built in battery backup, 
but mine lacked the battery.
step 6: you'll receive the motorola by mail, or have a tech install it, 
they actually had a tech in my area and I had an AT&T tech at my door in 
less than 20 minutes from when I got off the phone with tier-2 (I about 
died from the shock).
step 7: configure the motorola (192.168.1.254) for passthrough, 
DHCPS-dynamic, disable the firewall, the "advanced" firewall, hpna, 
wireless, etc.
Step 8: reboot to push the public IP to your real router.
step 9: head over to the Motorola's home network tab, and in the status 
window you'll see:


    IPv6

Status 	Available
Global IPv6 Address 	2602:306:cddd:xxxx::1/64
Link-local IPv6 Address 	fe80::923e:abff:xxxx:7e40
Router Advertisement Prefix 	2602:306:cddd:xxxx::/64
IPV6 Delegated LAN Prefix 	2602:306:cddd:xxxx::
2602:306:cddd:xxxx::


In reality additional poking leads me to believe AT&T gives you a rather 
generous /60, but how to use it?
step 10: set up dhcpv6, example for mikrotik follows (but should be 
easily convertible to nearly any router):

/ipv6> export
# dec/31/2001 20:26:03 by RouterOS 6.6
# software id = 5F2Y-X73L
#
/ipv6 address
add address=2602:306:cddd:xxxx::1 from-pool=AT&T interface=bridge1
/ipv6 dhcp-client
add add-default-route=yes interface=ether10 pool-name=AT&T

I hope that this is of help to someone.

Andrew



More information about the NANOG mailing list