juniper mx80 vs cisco asr 1000

Vinny Abello vinny at abellohome.net
Wed Jan 25 13:45:40 CST 2012


On 1/25/2012 10:50 AM, Nick Hilliard wrote:
> On 25/01/2012 15:17, Julien Goodwin wrote:
>> 2. Backspace doesn't work. Seriously (ok Ctrl-h works, and you can patch
>> your terminal emulator for it, but it's the only hardware I've used in
>> the last 15 years like that)
> 
> I ended up remapping backspace to <CTRL-H> too.
> 
> Yeah, seriously, this is totally bizarre dysfunction.  There might have
> been some excuse for it in the late 1980s, maybe even the early 1990s.  But
> the world moved on many, many years ago.

Same here... Likewise, up to a certain firmware version, the input would wrap to a second line making it difficult to backspace. Thankfully that is now fixed. The biggest issue I have now is modern security patched versions of putty just explode when talking to that gear with "type 2 (protocol error) Bad String Length" messages. It's one of those things where putty works fine with everything else as well as every other terminal program works fine with Brocade... so who's at fault? :-P

I've got 4 of the XMR 4000's and been running them for years. Most of the problems have been firmware bugs... Early ones were killers and caused inconsistencies in the routing topology, but I haven't seen anything to that extent again. The last major issue I had was the management cards on two of the boxes, about 2500 miles apart, both decided to go insane within hours of each other. I think a line card crashed if I remember right, the boxes stayed up, the management module stopped responding. Some traffic was being black-holed while other traffic continued flowing. After we already fixed it, a Brocade tech said that it sounded like a bus hang or something of that nature which can usually be fixed by re-seating the fan tray(??!?) so you don't need to reboot. We simply power cycled both. 

Another annoying bug I ran into which prompted a call to Brocade in the middle of the night... I couldn't update the firmware via SSH (nor could they). It kept failing on committing one of the firmware files after it was transferred. Turns out it was a bug and the workaround was to use telnet. The fix was in the version I was upgrading to. <sigh> It also would have been nice to know that before the tech said just reboot it and it should be fine and we followed all the upgrade steps (despite the errors saying it failed)... the line card's firmware didn't match and wouldn't boot as a result. Luckily this XMR was two blocks from where I was sitting and I recovered it, but still annoying. This is what someone else mentioned about all the firmware files needed just to upgrade. There is a combo file, but it doesn't cover everything.

One might try to seek out a Telehouse IIX engineer for another opinion. Being a customer of theirs on the NYIIX peering exchange, I know of many issues and outages that were all seemingly related to the MLXe's on which they now run the exchange. On the flip side, find some Hurricane Electric folk. I could be wrong, but I believe their entire backbone is built on the XMR. I know I've seen them in carrier hotels with their name on the equipment. One is two cabinets down from my own in the same cage.

Personally, I like the products on paper. Using them in production slightly lowers my satisfaction with them, but you definitely get a lot for your money... bugs and all.

-Vinny




More information about the NANOG mailing list