Trouble with IPv6 setup on Quagga

Vicky Shrestha vicky at geeks.net.np
Thu Aug 9 14:55:26 CDT 2012


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


On Aug 7, 2012, at 1:51 AM, Marco Hogewoning wrote:

>> I am having trouble with Quagga in setting up IPv6 BGP. So far it was
>> failing with external providers. Just now I gave it a try to setup BGP
>> session (IPv6 only) within our ASN between two routers.
>> 
>> From our other end router I see there is no acconcement, while I see blocks
>> being announced via Quagga. Also strange enough is that the number of
>> blocks I account - they all come as "withdrawl routes" on other router as
>> soon as Quagga is turned on.
> 
> I recall some issues with the value of the next-hop in the BGP messages in the past. Haven't been around Quagga in recent times, don't know if this is still the case. If possible you might want to catch a BGP packet with tcpdump and verify the value in there makes sense to the other side.
> 

We were having those issue with quagga-0.99.15 and cisco routers; haven't tested recent versions.  

We used a route map to fix the ipv6 next hop for outbound announcements in quagga.


> Got bitten by this before and took me ages to figure out the other side was dropping my updates because the next-hop couldn't be resolved.
> 
> Marco

Regards,


Vicky Shrestha



-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.8 (Darwin)

iQEcBAEBAgAGBQJQJBWuAAoJEGi4SIJCvhMLKhQH/i7dWdxBRh/2JyR0C/lWppq7
/y67GAUJo6Bc68Hpyma8BzNeYo/+YRarDbpz07dCFbzEHMiTrSLdN/CMVUWAkYxF
YBRXIIQuTRx8X+JYCx+egi7WDDHreIljE39OUmNtSZR0NVf3Ygot5qKXbDSqzFgJ
4RuxnYgI2ZBNN3X9up+PWJNdYI/49KanDl3RX62cGjQLQSqQRQWiwMWCXK0ufF2E
+xCZeUvkiqXnKWlF030ypHorGZoKX4JyuAj6SeS9yP1NTHgP6E57Xa0lvZ+v61Gx
Dml0o9JptNTctJ1cDeeWahRlgJx4yjfyUe0ZyIZAz9drZ4tgb3trC9cCHMNVV7Y=
=jFdq
-----END PGP SIGNATURE-----



More information about the NANOG mailing list