Strange L2 failure

ML ml at kenweb.org
Sat Jan 29 20:47:56 CST 2011


On 1/29/2011 4:24 PM, Jack Bates wrote:
> Has anyone seen issues with IOS where certain MACs fail?
>
> 54:52:00 (kvm) fails out an old 10mbit port on a 7206 running 12.2 SRE.
> I've never seen anything like this. DHCP worked, ARP worked, and arp
> debugging showed responses for arp to the MAC, however, tcpdump on the
> host system showed no unicast or arp responses coming from the router,
> while the switch management ip and other stuff on the local segment
> communicated fine with the vm. This broke for IPv6 as well.
>
> I changed the vm's MAC to 54:51:00, 50:52:00 and still failed. Changed
> it to 40:52:00 and it works for both v4 and v6. Was there a change which
> would cause certain hardware to not accept a MAC starting with 50: or
> higher?
>
>
> Jack
>


I just ran into something like this yesterday.  A Belkin router with a 
MAC of 9444.52dc.XXXX was properly learned at the IDF switch but the 
upstream agg switch/router wouldn't learn it.  I even tried to static 
the MAC into the CAM..router refused.

After changing the MAC address, everything worked.

Best I can figure the router treated it like a broadcast MAC. DHCP 
snooping at the IDF and the upstream aggregation switch/router learned 
the IP/MAC/interface lease information.  ARP entry at the router had the 
correct IP/MAC binding. Nothing in the CAM for the MAC of that darn Belkin.




More information about the NANOG mailing list