IPv4 Multicast

Rens rens at autempspourmoi.be
Wed May 26 08:21:28 CDT 2010


I have all those things you mentioned below.
The VLC server (10.0.1.2) sends out 2 streams on 239.255.0.1 & 239.255.0.2
I see both in SAP, when I try to join 239.255.0.2, nothing happens in VLC
and below you have the output of my routers & switches at that time:

On my RP router I see for show ip mroute:

(*, 239.255.255.255), 5d04h/00:03:26, RP 172.16.0.2, flags: SJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/1, Forward/Sparse, 1d06h/00:03:26
    FastEthernet0/0.200, Forward/Sparse, 5d04h/00:02:41

(10.0.1.2, 239.255.255.255), 1d06h/00:03:28, flags: LT
  Incoming interface: FastEthernet0/0.200, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/1, Forward/Sparse, 1d06h/00:03:26

(*, 239.255.0.2), 00:01:10/00:03:19, RP 172.16.0.2, flags: S
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/1, Forward/Sparse, 00:01:10/00:03:19

(*, 239.255.255.250), 00:07:19/00:03:07, RP 172.16.0.2, flags: S
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/1, Forward/Sparse, 00:07:22/00:03:03

(*, 239.195.255.255), 1d06h/00:02:39, RP 172.16.0.2, flags: S
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/1, Forward/Sparse, 00:01:24/00:02:39

(*, 224.2.127.254), 5d04h/00:03:10, RP 172.16.0.2, flags: SJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/1, Forward/Sparse, 1d06h/00:03:10
    FastEthernet0/0.200, Forward/Sparse, 5d04h/00:02:38

(*, 224.0.1.40), 5d04h/00:02:40, RP 172.16.0.2, flags: SJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/1, Forward/Sparse, 1d06h/00:02:59
    FastEthernet0/0.200, Forward/Sparse, 5d04h/00:02:40

On my other router I have:

(*, 239.255.255.255), 5d04h/stopped, RP 172.16.0.2, flags: SJCL
  Incoming interface: FastEthernet0/1, RPF nbr 192.168.0.2
  Outgoing interface list:
    FastEthernet0/0.200, Forward/Sparse, 5d04h/00:02:54

(10.0.1.2, 239.255.255.255), 1d06h/00:02:58, flags: LJT
  Incoming interface: FastEthernet0/1, RPF nbr 192.168.0.2
  Outgoing interface list:
    FastEthernet0/0.200, Forward/Sparse, 1d06h/00:02:54

(*, 239.255.0.2), 00:01:55/00:02:56, RP 172.16.0.2, flags: SJC
  Incoming interface: FastEthernet0/1, RPF nbr 192.168.0.2
  Outgoing interface list:
    FastEthernet0/0.200, Forward/Sparse, 00:01:55/00:02:56

(*, 239.255.255.250), 00:08:04/00:02:53, RP 172.16.0.2, flags: SJC
  Incoming interface: FastEthernet0/1, RPF nbr 192.168.0.2
  Outgoing interface list:
    FastEthernet0/0.200, Forward/Sparse, 00:08:04/00:02:53

(*, 239.195.255.255), 5d04h/00:02:50, RP 172.16.0.2, flags: SJC
  Incoming interface: FastEthernet0/1, RPF nbr 192.168.0.2
  Outgoing interface list:
    FastEthernet0/0.200, Forward/Sparse, 00:02:08/00:02:50

(*, 224.2.127.254), 5d04h/00:02:48, RP 172.16.0.2, flags: SJCL
  Incoming interface: FastEthernet0/1, RPF nbr 192.168.0.2
  Outgoing interface list:
    FastEthernet0/0.200, Forward/Sparse, 5d04h/00:02:48

(*, 224.0.1.40), 5d04h/00:02:52, RP 172.16.0.2, flags: SJCL
  Incoming interface: FastEthernet0/1, RPF nbr 192.168.0.2
  Outgoing interface list:
    FastEthernet0/0.200, Forward/Sparse, 5d04h/00:02:52

On the switch where the RP is connected:

Vlan      Group          Version     Port List
---------------------------------------------------------
200       224.0.1.40     v2          Gi2/24
200       224.2.127.254  v2          Gi2/24
200       239.255.255.255v2          Gi2/24

On the switch where the receiver is connected:

Vlan      Group                    Type        Version     Port List
-----------------------------------------------------------------------
200       224.0.1.40               igmp        v2          Gi0/24
200       224.2.127.254            igmp        v2          Gi0/1, Gi0/24
200       239.195.255.255          igmp        v2          Gi0/1, Gi0/24
200       239.255.0.2              igmp        v2          Gi0/1, Gi0/24
200       239.255.255.250          igmp        v2          Gi0/2, Gi0/24
200       239.255.255.255          igmp        v2          Gi0/1, Gi0/24

-----Original Message-----
From: Jamie Sobczyk [mailto:lanson9 at cox.net] 
Sent: vendredi 21 mai 2010 16:52
To: rens at autempspourmoi.be
Cc: nanog at nanog.org
Subject: RE: IPv4 Multicast

Make sure you have
"ip multicast-routing"
on both routers.

On the router interfaces, make sure you have
"ip pim sparse-mode"

On both routers, make sure you have the same rp address assigned and 
that you can ping this ip address from both routers. (I prefer to make 
it a loopback interface)
"ip pim rp-address w.x.y.z"

Also, make sure that routing is setup on your routers so that your 
receiver can ping your sender.

On your routers you should be able to see the source unicast address and 
multicast address by typing "show ip mroute"
you should see something like this:
(*, 239.192.3.47), 7w0d/00:02:59, RP 10.31.0.1, flags: S
   Incoming interface: Null, RPF nbr 0.0.0.0
   Outgoing interface list:
     Port-channel15, Forward/Sparse, 7w0d/00:02:59, H

(10.5.9.51, 239.192.3.47), 4w5d/00:03:27, flags: TA
   Incoming interface: Port-channel15, RPF nbr 10.7.193.138
   Outgoing interface list:
     Port-channel17, Forward/Sparse, 4w5d/00:02:49, H

On your switches, with igmp snooping enabled, you should be able to 
type:
"show ip igmp snooping group" and see something like
Vlan      Group                    Type        Version     Port List
-----------------------------------------------------------------------
24        239.192.3.47             igmp        v2          Gi1/0/21
That port listed is the port of the requester.




-----Original Message-----
I have setup a lab for this multicast.

VLC receiver - 3560G - 1841 - 1841 - 4503 - VLC sender

The 2 switches only provide L2 access, they have IGMP snooping active

On both 1841's I have pim parse-mode & sap listen on all interfaces +
configured a static RP, the one closest to the sender.

With my VLC receiver I can see the channels via SAP, but when I join the
multicast group I don't receive anything.

Could someone help me to troubleshoot this?

Thanks in advance,

Rens






More information about the NANOG mailing list