PPP multilink help

Dan White dwhite at olp.net
Mon May 11 09:54:29 CDT 2009


Andrey Gordon wrote:
> Hey folks, I'm sure to you it's peanuts, but I'm a bit puzzled (most likely
> because of the lack of knowledge, I bet).
>
> I'm buying an IP backbone from VNZ (presumably MPLS). I get a MLPPP hand off
> on all sites, so I don't do the actual labeling and switching, so I guess
> for practical purposes what I'm trying to say is that I have no physical
> control over the other side of my MLPPP links.
>
> When I transfer a large file over FTP (or CIFS, or anything else), I'd
> expect it to max out either one or both T1, but instead utilization on the
> T1s is hoovering at 70% on both and sometimes MLPPP link utilization even
> drops below 50%. What am I'm not gettting here?
>   

I seem to be in a similar situation as you (but with AT&T). I have not 
noticed any unexpected missing bandwidth.

I don't see any specific problems with your config, but I'll include 
mine in hopes it will be useful:

controller T1 0/0/0
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24
!
controller T1 0/0/1
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24
!
class-map match-any imaging
 match access-group 112
class-map match-any rdp
 match access-group 113
class-map match-any voice
 match ip dscp ef
 match access-group 110
!
policy-map private_wan
 class voice
  priority percent 60
  set ip dscp ef
 class rdp
  bandwidth percent 32
  set ip dscp af31
 class imaging
  bandwidth percent 4
  set ip dscp af21
 class class-default
  bandwidth percent 4
  set ip dscp default
!
interface Multilink1
 ip address x.x.x.38 255.255.255.252
 no keepalive
 no cdp enable
 ppp chap hostname xxxxxxx
 ppp multilink
 ppp multilink fragment disable
 ppp multilink group 1
 max-reserved-bandwidth 100
 service-policy output private_wan
!
interface Serial0/0/0:0
 no ip address
 encapsulation ppp
 no cdp enable
 ppp chap hostname xxxxxxxxxx
 ppp multilink
 ppp multilink group 1
 max-reserved-bandwidth 100
!
interface Serial0/0/1:0
 no ip address
 encapsulation ppp
 no cdp enable
 ppp chap hostname xxxxxxxxxx
 ppp multilink
 ppp multilink group 1
 max-reserved-bandwidth 100
!
access-list 110 permit ip any 10.0.0.0 0.0.255.255
access-list 110 permit ip 10.0.0.0 0.0.255.255 any
access-list 110 permit icmp any any
access-list 112 permit ip any host x.x.x.x
access-list 113 permit ip any host x.x.x.x





More information about the NANOG mailing list