Data Center QoS equipment breaking http 1.1?

up at 3.am up at 3.am
Fri Jul 31 16:25:23 CDT 2009


Sorry if this is a little OT, but we're seeing a serious problem and was 
wondering if it is what I think it is.

In short: I have been moving services off of our servers in a data center 
onto a server at eSecuredata, who rents dedicated servers.  The idea is to 
lower costs and eliminate having to deal with hardware.

The advertise "unmetered bandwidth", but mention QoS measure to control 
"bandwidth hogs".

One of my customers, whose site I just moved from a unique IP virtual host 
on my old server onto an Apache NameVirtualHost on the new one, worked 
fine at first.  Then today, they started complaining about getting one of 
our home pages.  I figured DNS or web caching issues, until I started 
seeing it for myself.  It was no caching issue, it was NameVirtualHost 
breaking.

I poured over my configs (I've done this config countless times), and saw 
this in the apache docs:

http://httpd.apache.org/docs/2.2/vhosts/name-based.html

" Some operating systems and network equipment implement bandwidth 
management techniques that cannot differentiate between hosts unless they 
are on separate IP addresses."

So, I installed lynx on the server, and sure enough, it worked perfectly 
fine there, just not from anywhere outside eSecuredata's network that I 
could see.

Can anyone shed any light on this particular practice, of this company in 
particular?

thanks

James Smallacombe		      PlantageNet, Inc. CEO and Janitor
up at 3.am							    http://3.am
=========================================================================




More information about the NANOG mailing list