Seeking clue @ Cbeyond / ASN17184 and/or other suggestions

Mike Lewinski mike at rockynet.com
Wed Jun 25 10:51:33 CDT 2008


I'm very happy to report that my post here found the necessary 
clue-holders and resolved both the lame DNS and stale email 
configuration issue.

Also, one important followup wrt the whois for their ASN query:

> Finally, as an additional note, the whois delegation for their ASN seems 
> to be broken:
> 
> $ whois -h whois.arin.net 17184
> [Querying whois.arin.net]
> [Redirected to rwhois.cbeyond.net:4321]
> [Querying rwhois.cbeyond.net]
> [rwhois.cbeyond.net]
> %rwhois V-1.5:003eff:00 rwhois.cbeyond.net (by Network Solutions, Inc. 
> V-1.5.9.5)
> %error 230 No Objects Found
> $

It appears that the breakage is probably in my whois client (though, the 
exact problem has yet to be diagnosed).

The standard whois client for CentOS 5.1 still returns the 230 error:

$ whois -h whois.arin.net AS17184
[Querying whois.arin.net]
[Redirected to rwhois.cbeyond.net:4321]
[Querying rwhois.cbeyond.net]
[rwhois.cbeyond.net]
%rwhois V-1.5:003eff:00 rwhois.cbeyond.net (by Network Solutions, Inc. 
V-1.5.9.5)
%error 230 No Objects Found


I had one private reply pointing out that my original syntax was wrong 
in omitting the "AS" string, though I'd tried it every way I could 
imagine, and verified that the syntax worked for other ASNs.

The whois client on my OS X 10.4 returns the desired results:

$ whois -h whois.arin.net AS17184

OrgName:    CBEYOND COMMUNICATIONS, LLC
OrgID:      CBEY
Address:    320 Interstate North Parkway
Address:    Suite 300
City:       Atlanta
StateProv:  GA
PostalCode: 30339
Country:    US

<snip>

On my ToDo is to dig deeper into the problem and figure out who needs a 
bug report to fix this. I'm guessing it lies with CentOS/RHEL, and has 
to do with a failure to use the custom whois port assignment @ Cbeyond.

Thanks for all the private replies, especially the one that lead to this 
resolution!

Mike




More information about the NANOG mailing list