F-ckin Leap Seconds, how do they work?

Chuck Anderson cra at WPI.EDU
Sat Jun 30 23:57:35 CDT 2012


Same here with KVM guests on Scientific Linux 6 (RHEL 6 clone) hosts.
No issues on SL 6 and CentOS 5 guests.  We also do not run NTP on the
VMs, only on the hosts.  The guest VM kernels did not log any leap
second clock change, but appear to have the same time as the hosts.

The hosts DID have issues though.  The "reset the date" workaround
solved the issue immediately, with no requirement to restart anything,
including ntpd.  The hosts logged leap second clock updates:

Jun 30 19:59:59 vmhost kernel: Clock: inserting leap second 23:59:60 UTC

My Fedora 16 laptop was also being sluggish due to chromium-browser
sucking up CPU.  That too was fixed immediately by resetting the date.

On Sun, Jul 01, 2012 at 12:41:25AM -0400, Derek Ivey wrote:
> We haven't had any issues with any of our VMs. We run several of our
> own Java/Tomcat apps, Jira, and Confluence on a mixture of Solaris
> and CentOS 5 and 6. We do not run NTP on our VMs though; instead, we
> rely on VMware Tools to sync the VMs' time with the ESXi hosts. The
> ESXi hosts run NTP.
> 
> On 6/30/2012 11:16 PM, George Bonser wrote:
> >>>Anything with java running seems hit.
> >>>We just finished up a firm round of reboots... :(
> >>>
> >>>Recent Ubuntu boxes and RHES 6... all the same ...
> >>>
> >>>Bye,
> >>>Raymond.
> >>>
> >>>
> >>Yeah, in the process of doing the same.
> >>
> >>http://news.ycombinator.com/item?id=4183122
> >>
> >>Might try this for machines with Java applications in order to avoid
> >>reboot:
> >>
> >>https://bugzilla.mozilla.org/show_bug.cgi?id=769972
> >>
> >>
> >>See comment 5
> >>
> >>
> >And we have verified that this clears the issue for us.  YMMV.



More information about the NANOG mailing list