eigrp distribute-list out vlan interface

Andrey Khomyakov khomyakov.andrey at gmail.com
Wed Nov 10 09:01:02 CST 2010


Need to manipulate metric out to only one of the EIGRP neighbors only for
default route.
Trying to use distribute-list (can't think of anything else that can do that
for me)
The metric in the distribute-list does not seem to affect the default route
at all. It still comes through with the metric of the redistribute command.
I tried it in the lab and it worked.
In the lab I used 3725 routers and physical interfaces.
In production I have 4507R SUP6 and using a vlan interaface.

Does anyone have any thoughts on why this does not work. Are vlan interfaces
just not supported or is it a bug? Or am I misusing distribute-list all
together?

router eigrp 179
 distribute-list route-map eigrp-redistribute-to-worcester out Vlan2517
 network 0.0.0.0
 redistribute static route-map eigrp-redistribute
 eigrp router-id 10.0.0.3

ip prefix-list all-routes permit 0.0.0.0/0 le 32
!
ip prefix-list eigrp-redistribute permit 10.0.28.0/24
ip prefix-list eigrp-redistribute permit 10.6.4.0/24
!
ip prefix-list eigrp-redistribute-default permit 0.0.0.0/0
!
ip route 0.0.0.0 0.0.0.0 192.168.168.10
ip route 10.0.28.0 255.255.255.0 192.168.168.22
ip route 10.6.4.0 255.255.255.0 192.168.168.22
!
route-map eigrp-redistribute permit 10
 match ip address prefix-list eigrp-redistribute
 set metric 100000 1 255 1 1500
!
route-map eigrp-redistribute permit 20
 match ip address prefix-list eigrp-redistribute-default
 set metric 100000 10 255 1 1500
!
route-map eigrp-redistribute-to-worcester permit 10
 match ip address prefix-list eigrp-redistribute-default
 set metric 50000 10 255 1 1500
!
route-map eigrp-redistribute-to-worcester permit 20
 match ip address prefix-list all-routes

-- 
Andrey Khomyakov
[khomyakov.andrey at gmail.com]



More information about the NANOG mailing list