SMTP no-such-user issues

Frank Bulk - iNAME frnkblk at iname.com
Tue Jun 17 07:39:29 CDT 2008


Please share a packet capture of a working and not working SMTP exchange.

Frank

-----Original Message-----
From: Steve Bertrand [mailto:steve at ibctech.ca] 
Sent: Tuesday, June 17, 2008 6:14 AM
To: nanog at nanog.org
Subject: Re: SMTP no-such-user issues

Steve Bertrand wrote:
> Hi everyone,
>
> We are experiencing an issue in regards to SMTP MTA relay responses
> regarding 'no such user', and it *apparently* appears to be only
> occurring when a particular site attempts to deliver email to us. Any
> advice on how to further troubleshoot my issue would be greatly
> appreciated.

Because I have been inundated with off-list replies, I'll post my
findings here.

First, a screen cap of me composing a message, in which two of the
addresses are easily identified as valid, and two are clearly not:

http://ibctech.ca/nanog_smtp/hotmail_compose.jpg

...when I sent it, I received thus:

http://ibctech.ca/nanog_smtp/hotmail_response.txt

So, we'll try it from a different server:

http://ibctech.ca/nanog_smtp/local_compose.jpg

...hmmm, I received the message at steveb at eagle.ca (even though the To:
field was cropped out of the jpg) this time, and my server generated the
following....AFAICT, correct 551 error(s):

http://ibctech.ca/nanog_smtp/local_err.txt

I'm willing to provide any more documentation required in order to get
this issue sorted.

Thank you everyone, I truly appreciate it.

Steve











More information about the NANOG mailing list